MEISTING

ipv6 nat 后会对 pt 上传有影响吗

  •  
  •   MEISTING · May 26, 2018 · 7530 views
    This topic created in 3082 days ago, the information mentioned may be changed or developed.
    不是很清楚会不会像 v4 影响上传
    46 replies  •  2018-05-28 14:52:31 +08:00
    kesu
    kesu
    May 26, 2018
    1
    应该不会的,我用路由器也是经过 ipv6 nat,日常使用 ipv6 下载能达到满速,上传的话,可能不是自己做种的原因,最高有 5m/s。
    kmahyyg
    kmahyyg
    May 26, 2018 via iPad
    2
    看 nat 类型, 可能对外网连接你的 peer 有影响, 不过速度一般不会有, 因为我这里就是这样
    yjzll
    yjzll
    May 26, 2018
    3
    想知道如何 ipv6
    MEISTING
    MEISTING
    OP
    May 26, 2018
    4
    @kesu 下载是肯定没问题的,就是不知道上传比直接用 v6 的公网 ip 差多少
    kesu
    kesu
    May 26, 2018
    5
    @MEISTING #4 这个你可以自己做种试一下,应该可以跑满~
    dlsflh
    dlsflh
    May 26, 2018 via Android
    6
    没有影响
    mt7620
    mt7620
    May 26, 2018 via Android
    7
    ipv6 为什么还要 nat ???
    yexm0
    yexm0
    May 26, 2018 via iPhone
    8
    @mt7620 可能是学校那种的吧,只给一个地址给他们用
    237176253
    237176253
    May 26, 2018 via Android
    9
    @yexm0 是的 dhcp 一个端口只给一个 v6 ip
    LGA1150
    LGA1150
    May 26, 2018 via Android
    10
    @237176253 如果是 SLAAC 给 /64 中的一个的话,可以 odhcpd relay
    fancyhan
    fancyhan
    May 26, 2018
    11
    @237176253 #9 弄个虚拟交换机
    MEISTING
    MEISTING
    OP
    May 26, 2018
    12
    @LGA1150 怎么看是不是 SLAAC 的。。。
    LGA1150
    LGA1150
    May 26, 2018
    13
    @MEISTING 接口掩码是不是 /64
    237176253
    237176253
    May 26, 2018 via Android
    14
    @LGA1150 128 的
    MEISTING
    MEISTING
    OP
    May 26, 2018
    15
    @LGA1150 路由器 ifconfig 看到的
    inet6 addr: fe80::2eb2:1aff:fefe:b336/64 Scope:Link
    inet6 addr: 2001:da8:6000:e02::1dd8/128 Scope:Global
    237176253
    237176253
    May 26, 2018 via Android
    16
    @LGA1150 我的网线看是 128,是不是不是 slaac?
    LGA1150
    LGA1150
    May 26, 2018
    17
    看来是 DHCPv6,不过你依然可以试试 relay
    编辑 /etc/config/dhcp
    config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option ra 'relay'
    option ndp 'relay'

    config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

    config dhcp 'wan6'
    option interface 'wan'
    option ra 'relay'
    option ndp 'relay'
    option master '1'
    其他部分别动
    取消原有的 NAT6 设置,重启
    LGA1150
    LGA1150
    May 26, 2018
    18
    刚才漏了 option dhcpv6 'relay' ,在 lan 和 wan6 处补上
    MEISTING
    MEISTING
    OP
    May 26, 2018
    19
    @LGA1150 这个可以几台 pc 同时使用吗?之前的 padavan 穿透了下只可以一台用
    LGA1150
    LGA1150
    May 26, 2018
    20
    @MEISTING 可以
    MEISTING
    MEISTING
    OP
    May 26, 2018
    21
    @LGA1150 只改这些吗?改了后我获取到了很奇怪的 v6 地址,没法上网
    LGA1150
    LGA1150
    May 26, 2018
    22
    @MEISTING 比如?
    MEISTING
    MEISTING
    OP
    May 26, 2018
    23
    @LGA1150 查了下是保留地址。。。nat 后速度也不差,能跑 300m 也够了,不折腾了
    LGA1150
    LGA1150
    May 26, 2018
    24
    @MEISTING 也可试试桥接
    MEISTING
    MEISTING
    OP
    May 26, 2018
    25
    @LGA1150 折腾太久了,不想搞了。。。
    geekzu
    geekzu
    May 26, 2018 via Android
    26
    @LGA1150 CERNET2 一般都是 DHCPv6 /128,无法 Relay
    MEISTING
    MEISTING
    OP
    May 26, 2018 via Android
    27
    @geekzu 要多台设备用一个网口是不是只能 nat 了?
    angles6645
    angles6645
    May 26, 2018 via Android
    28
    你们不能把路由器当成交换机使吗😂这样就能直接拿到 IP 了
    MEISTING
    MEISTING
    OP
    May 26, 2018 via Android
    29
    @zst v4 需要认证 这样做 v4 就混乱了
    LGA1150
    LGA1150
    May 26, 2018
    30
    @geekzu 我这里是 SLAAC

    @MEISTING 所以要用到 ebtables,v6 桥接、v4 路由
    MEISTING
    MEISTING
    OP
    May 26, 2018
    31
    @LGA1150 有 openwrt 的教程吗。。。我明天试试
    zro
    zro
    May 26, 2018
    33
    加个交换机就简单多了,路由器 WAN、LAN 口各接一条线到交换机就可以了
    MEISTING
    MEISTING
    OP
    May 26, 2018 via Android
    34
    @Love4Taylor
    ebtables -t broute -A BROUTING -p ! ipv6 -j DROP -i $interface
    这一步报错 我是 openwrt 可能哪些参数要改?
    MEISTING
    MEISTING
    OP
    May 26, 2018 via Android
    35
    @MEISTING 没报错 我搞错了。。。
    geekzu
    geekzu
    May 26, 2018 via Android
    36
    @MEISTING 我是路由器上 etables 桥接 ipv6 数据包解决的


    @LGA1150 那应该是早期建设的,后期建设的全是 DHCPv6 了,估计是统一规范
    MEISTING
    MEISTING
    OP
    May 26, 2018
    37
    @geekzu 我换 padavan 后桥接解决了,就是不知道怎么每次开机执行语句
    ZRS
    ZRS
    May 27, 2018
    38
    网件的路由自带 ipv6 穿透模式,就是 v6 桥接 v4 NAT 用着感觉还可以 上下行最高都能跑到 400M 以上
    skylancer
    skylancer
    May 28, 2018
    39
    @mt7620 以下几种情况可能会考虑 v6 NAT
    1. 只给一个而不是一段
    2. 为隐私考虑,毕竟 Stateless 知道你 mac 就知道你 IP,而且
    1). Android 坑爹
    2). iOS 不走隐私模式 IP,呵呵
    MEISTING
    MEISTING
    OP
    May 28, 2018 via Android
    40
    @skylancer 我这 dhcp v6 的,nat 后安卓能用,直接桥接反倒不行
    cwbsw
    cwbsw
    May 28, 2018
    41
    @skylancer
    Windows 和 iOS 的 IPV6 主机位都不是直接由 MAC 地址生成的。
    Windows 的首选地址主机位与 Local Link 地址相同,iOS 是不同的。
    经测试 iOS 主动发起连接会使用临时地址而非首选地址。
    skylancer
    skylancer
    May 28, 2018
    42
    @cwbsw Stateless 和隐私模式是两回事
    cwbsw
    cwbsw
    May 28, 2018
    43
    @skylancer 难道不是指 RFC4941 定义的隐私扩展?
    cwbsw
    cwbsw
    May 28, 2018
    44
    @skylancer
    继续测试了一下,iOS 不仅实现了 RFC4941 的临时地址,而且还会在不同的网络使用不同的接口 ID 生成不同的首选地址。
    cwbsw
    cwbsw
    May 28, 2018
    45
    也就是 RFC8064、RFC7217。
    skylancer
    skylancer
    May 28, 2018
    46
    @cwbsw 是,但是是两回事啊。另外我也看了下,现在正常了,以前是有 bug 不走
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   5072 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 48ms · UTC 00:16 · PVG 08:16 · LAX 16:16 · JFK 19:16
    ♥ Do have faith in what you're doing.